Degraded service caused by underlying Azure outage
Affected components
Updates

Write-up published

Read it here

Resolved

The issue with Azure Front Door and related network connectivity has been mitigated and is now fully resolved. Our monitoring confirms all systems are stable.

Thu, Oct 9, 2025, 06:47 PM

Monitoring

Things appear stable on our end, we are continuing to monitor the situation closely until Microsoft confirms full resolution and officially closes the incident.

Thu, Oct 9, 2025, 03:12 PM(3 hours earlier)

Investigating

Microsoft Azure Frontdoor outage confirmed on their status page,

source: https://azure.status.microsoft/en-us/status

Thu, Oct 9, 2025, 10:11 AM(5 hours earlier)

Investigating

We are currently experiencing a partial service disruption due to an ongoing issue with our cloud provider, Microsoft Azure. Some services may be degraded or intermittently unavailable. We are monitoring the situation closely and will provide updates as needed.

Thu, Oct 9, 2025, 08:51 AM(1 hour earlier)
Powered by